Pertemuan pertama dihadiri bos Ipin, Hafiz, dan Irfan
Tema yang dibahas adalah Simulasi CISCO MPLS-L3VPN menggunakan GNS-3(PE-CE with OSPF). (PE-To-CE OSPF with same process ID). Untuk menyebrangkan BGP di router Core sampai ke PE digunakan MPBGP. Selain itu diperlukan IOS router Core dan PE yang support BGP (seri 7200).
Untuk mempermudah digambarin dulu Topologi nya adalah seperti gambar dibawah ini:
Konfigurasi IP addressnya adalah sebagai berikut:
Langkah-langkahnya adalah sebagai berikut:
Pertama: configure semua interface (PE1-Core-PE2)
---------------core----------------------
!
interface Loopback0
ip address 192.168.100.1 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.10 255.255.255.252
!
interface GigabitEthernet2/0
ip address 192.168.10.13 255.255.255.252
-----------------------------------------
---------------PE1-----------------------
interface Loopback0
ip address 192.168.100.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.9 255.255.255.252
-----------------------------------------
---------------PE2-----------------------
interface Loopback0
ip address 192.168.100.3 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.14 255.255.255.252
-----------------------------------------
Kedua: Aktifkan Dynamic Routing menggunakan OSPF, inget kembali konsep wilcard
---------------core----------------------
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.1 0.0.0.0 area 0
-----------------------------------------
---------------PE1-----------------------
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.2 0.0.0.0 area 0
-----------------------------------------
---------------PE2-----------------------
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.3 0.0.0.0 area 0
-----------------------------------------
Untuk pengecekan : ketikan show ip route
PE1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
C 192.168.10.8 is directly connected, GigabitEthernet1/0
O 192.168.10.12 [110/2] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
192.168.100.0/32 is subnetted, 3 subnets
O 192.168.100.1 [110/2] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
C 192.168.100.2 is directly connected, Loopback0
O 192.168.100.3 [110/3] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
PE1#
PE2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
O 192.168.10.8 [110/2] via 192.168.10.13, 00:18:13, GigabitEthernet1/0
C 192.168.10.12 is directly connected, GigabitEthernet1/0
192.168.100.0/32 is subnetted, 3 subnets
O 192.168.100.1 [110/2] via 192.168.10.13, 00:18:23, GigabitEthernet1/0
O 192.168.100.2 [110/3] via 192.168.10.13, 00:18:13, GigabitEthernet1/0
C 192.168.100.3 is directly connected, Loopback0
PE2#
Ketiga: Aktifkan BGP
---------------PE1-----------------------
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.100.3 remote-as 100
neighbor 192.168.100.3 update-source Loopback0
no auto-summary
-----------------------------------------
---------------PE2-----------------------
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.100.2 remote-as 100
neighbor 192.168.100.2 update-source Loopback0
no auto-summary
-----------------------------------------
Untuk pengecekan : ketikan show ip bgp sum
PE1# sh ip bgp summary
BGP router identifier 192.168.100.2, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.100.3 4 100 28 36 1 0 0 00:30:32 0
PE1#
PE2#sh ip bgp summary
BGP router identifier 192.168.100.3, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.100.2 4 100 35 28 1 0 0 00:23:27 0
PE2#
Keempat: Aktifkan MPLS dengan perintah ip cef
---------------core----------------------
ip cef
!
mpls label protocol ldp
!
interface GigabitEthernet1/0
ip address 192.168.10.10 255.255.255.252
mpls ip
!
interface GigabitEthernet2/0
ip address 192.168.10.13 255.255.255.252
mpls ip
-----------------------------------------
---------------PE1-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
ip address 192.168.10.9 255.255.255.252
mpls ip
-----------------------------------------
---------------PE2-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
ip address 192.168.10.14 255.255.255.252
mpls ip
-----------------------------------------
Untuk pengecekan : ketikan show mpls ldp neighbor
core#show mpls ldp neighbor
Peer LDP Ident: 192.168.100.3:0; Local LDP Ident 192.168.100.1:0
TCP connection: 192.168.100.3.26601 - 192.168.100.1.646
State: Oper; Msgs sent/rcvd: 45/36; Downstream
Up time: 00:32:49
LDP discovery sources:
GigabitEthernet2/0, Src IP addr: 192.168.10.14
Addresses bound to peer LDP Ident:
192.168.10.14 192.168.100.3
Peer LDP Ident: 192.168.100.2:0; Local LDP Ident 192.168.100.1:0
TCP connection: 192.168.100.2.31760 - 192.168.100.1.646
State: Oper; Msgs sent/rcvd: 45/44; Downstream
Up time: 00:32:32
LDP discovery sources:
GigabitEthernet1/0, Src IP addr: 192.168.10.9
Addresses bound to peer LDP Ident:
192.168.10.9 192.168.100.2
core#
PE1#sh mpls ldp neighbor
Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.2:0
TCP connection: 192.168.100.1.646 - 192.168.100.2.31760
State: Oper; Msgs sent/rcvd: 43/44; Downstream
Up time: 00:31:35
LDP discovery sources:
GigabitEthernet1/0, Src IP addr: 192.168.10.10
Addresses bound to peer LDP Ident:
192.168.10.10 192.168.100.1 192.168.10.13
PE1#
PE2#show mpls ldp neighbor
Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.3:0
TCP connection: 192.168.100.1.646 - 192.168.100.3.26601
State: Oper; Msgs sent/rcvd: 37/45; Downstream
Up time: 00:25:54
LDP discovery sources:
GigabitEthernet1/0, Src IP addr: 192.168.10.13
Addresses bound to peer LDP Ident:
192.168.10.10 192.168.100.1 192.168.10.13
PE2#
Kelima: Buat Router Virtual (VRF : Virtual Routing Forwarding)
---------------PE1-----------------------
ip vrf cnc1
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface GigabitEthernet2/0
ip vrf forwarding cnc1
ip address 192.168.10.2 255.255.255.252
---------------PE2-----------------------
ip vrf cnc1
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface GigabitEthernet2/0
ip vrf forwarding cnc1
ip address 192.168.10.17 255.255.255.252
-----------------------------------------
untuk pengecekan : ketikan show ip vrf (name)
Keenam: Menambahkan Routing DiRouter Virtual
---------------PE1-----------------------
router ospf 100 vrf cnc1
log-adjacency-changes
redistribute bgp 100 subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.0.0.0 0.255.255.255 area 0
-----------------------------------------
---------------PE2-----------------------
router ospf 100 vrf cnc1
log-adjacency-changes
redistribute bgp 100 subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.0.0.0 0.255.255.255 area 0
-----------------------------------------
Ketujuh: Aktifkan MP-BGP
---------------PE1-----------------------
router bgp 100
bgp router-id 192.168.100.2
bgp log-neighbor-changes
neighbor 192.168.100.3 remote-as 100
neighbor 192.168.100.3 update-source Loopback0
!
address-family ipv4
neighbor 192.168.100.3 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.100.3 activate
neighbor 192.168.100.3 send-community both
exit-address-family
!
address-family ipv4 vrf cnc1
redistribute connected
redistribute ospf 100 vrf cnc1 match internal external 1 external 2
no synchronization
exit-address-family
!
-----------------------------------------
---------------PE2-----------------------
router bgp 100
bgp router-id 192.168.100.3
bgp log-neighbor-changes
neighbor 192.168.100.2 remote-as 100
neighbor 192.168.100.2 update-source Loopback0
!
address-family ipv4
neighbor 192.168.100.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.100.2 activate
neighbor 192.168.100.2 send-community both
exit-address-family
!
address-family ipv4 vrf cnc1
redistribute connected
redistribute ospf 100 vrf cnc1 match internal external 1 external 2
no synchronization
exit-address-family
-----------------------------------------
Untuk pengecekan : ketikan show ip vrf (name)
PE1#sh ip route vrf cnc1
Routing Table: cnc1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
C 192.168.10.0 is directly connected, GigabitEthernet2/0
B 192.168.10.16 [200/0] via 192.168.100.3, 00:21:01
10.0.0.0/32 is subnetted, 2 subnets
O 10.14.200.1 [110/2] via 192.168.10.1, 00:24:00, GigabitEthernet2/0
B 10.14.200.2 [200/2] via 192.168.100.3, 00:21:01
PE1#
PE2#sh ip route vrf cnc1
Routing Table: cnc1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
B 192.168.10.0 [200/0] via 192.168.100.2, 00:16:32
C 192.168.10.16 is directly connected, GigabitEthernet2/0
10.0.0.0/32 is subnetted, 2 subnets
B 10.14.200.1 [200/2] via 192.168.100.2, 00:16:32
O 10.14.200.2 [110/2] via 192.168.10.18, 00:19:02, GigabitEthernet2/0
PE2#
Setelah selesai sesi ini, sudah bisa ping antar PE1 ke PE2, selanjutnya adalah setting CE nya agar bisa berkomunikasi dengan cabang lainya dengan virtualisasi VRF yang disetting barusan.
Berikut detail nya
---------------cnc1_a--------------------
cnc1_a#sh run
!
version 12.4
!
hostname cnc1_a
!
enable secret 5 $1$3b6r$LdDX1wajQUqjGJPOpxH0F1
!
ip cef
!
interface Loopback0
ip address 10.14.200.1 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.1 255.255.255.252
negotiation auto
!
ip forward-protocol nd
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 xxxx
login
!
end
--------------cnc1_b---------------------
cnc1_b#sh run
!
version 12.4
!
hostname cnc1_b
!
enable secret 5 $1$BNrz$gJwJXNoaDp5X0F2ViVllF/
ip cef
!
interface Loopback0
ip address 10.14.200.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.18 255.255.255.252
negotiation auto
!
ip forward-protocol nd
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password xxxx
login
!
end
Tema yang dibahas adalah Simulasi CISCO MPLS-L3VPN menggunakan GNS-3(PE-CE with OSPF). (PE-To-CE OSPF with same process ID). Untuk menyebrangkan BGP di router Core sampai ke PE digunakan MPBGP. Selain itu diperlukan IOS router Core dan PE yang support BGP (seri 7200).
Untuk mempermudah digambarin dulu Topologi nya adalah seperti gambar dibawah ini:
Konfigurasi IP addressnya adalah sebagai berikut:
Loopback 0
|
G1/0
|
G2/2
|
|
Core
|
192.168.100.1/32
|
192.168.10.10/30
|
192.168.10.13/30
|
PE1
|
192.168.100.2/32
|
192.168.10.9/30
|
192.168.10.2/30
|
PE2
|
192.168.100.3/32
|
192.168.10.14/30
|
192.168.10.17/30
|
cnc1_a
|
10.14.200.1/32
|
192.168.10.1/30
|
|
cnc1_b
|
10.14.200.2/32
|
192.168.10.18/30
|
Langkah-langkahnya adalah sebagai berikut:
Pertama: configure semua interface (PE1-Core-PE2)
---------------core----------------------
!
interface Loopback0
ip address 192.168.100.1 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.10 255.255.255.252
!
interface GigabitEthernet2/0
ip address 192.168.10.13 255.255.255.252
-----------------------------------------
---------------PE1-----------------------
interface Loopback0
ip address 192.168.100.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.9 255.255.255.252
-----------------------------------------
---------------PE2-----------------------
interface Loopback0
ip address 192.168.100.3 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.14 255.255.255.252
-----------------------------------------
Kedua: Aktifkan Dynamic Routing menggunakan OSPF, inget kembali konsep wilcard
---------------core----------------------
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.1 0.0.0.0 area 0
-----------------------------------------
---------------PE1-----------------------
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.2 0.0.0.0 area 0
-----------------------------------------
---------------PE2-----------------------
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.3 0.0.0.0 area 0
-----------------------------------------
Untuk pengecekan : ketikan show ip route
PE1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
C 192.168.10.8 is directly connected, GigabitEthernet1/0
O 192.168.10.12 [110/2] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
192.168.100.0/32 is subnetted, 3 subnets
O 192.168.100.1 [110/2] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
C 192.168.100.2 is directly connected, Loopback0
O 192.168.100.3 [110/3] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
PE1#
PE2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
O 192.168.10.8 [110/2] via 192.168.10.13, 00:18:13, GigabitEthernet1/0
C 192.168.10.12 is directly connected, GigabitEthernet1/0
192.168.100.0/32 is subnetted, 3 subnets
O 192.168.100.1 [110/2] via 192.168.10.13, 00:18:23, GigabitEthernet1/0
O 192.168.100.2 [110/3] via 192.168.10.13, 00:18:13, GigabitEthernet1/0
C 192.168.100.3 is directly connected, Loopback0
PE2#
Ketiga: Aktifkan BGP
---------------PE1-----------------------
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.100.3 remote-as 100
neighbor 192.168.100.3 update-source Loopback0
no auto-summary
-----------------------------------------
---------------PE2-----------------------
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.100.2 remote-as 100
neighbor 192.168.100.2 update-source Loopback0
no auto-summary
-----------------------------------------
Untuk pengecekan : ketikan show ip bgp sum
PE1# sh ip bgp summary
BGP router identifier 192.168.100.2, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.100.3 4 100 28 36 1 0 0 00:30:32 0
PE1#
PE2#sh ip bgp summary
BGP router identifier 192.168.100.3, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.100.2 4 100 35 28 1 0 0 00:23:27 0
PE2#
Keempat: Aktifkan MPLS dengan perintah ip cef
---------------core----------------------
ip cef
!
mpls label protocol ldp
!
interface GigabitEthernet1/0
ip address 192.168.10.10 255.255.255.252
mpls ip
!
interface GigabitEthernet2/0
ip address 192.168.10.13 255.255.255.252
mpls ip
-----------------------------------------
---------------PE1-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
ip address 192.168.10.9 255.255.255.252
mpls ip
-----------------------------------------
---------------PE2-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
ip address 192.168.10.14 255.255.255.252
mpls ip
-----------------------------------------
Untuk pengecekan : ketikan show mpls ldp neighbor
core#show mpls ldp neighbor
Peer LDP Ident: 192.168.100.3:0; Local LDP Ident 192.168.100.1:0
TCP connection: 192.168.100.3.26601 - 192.168.100.1.646
State: Oper; Msgs sent/rcvd: 45/36; Downstream
Up time: 00:32:49
LDP discovery sources:
GigabitEthernet2/0, Src IP addr: 192.168.10.14
Addresses bound to peer LDP Ident:
192.168.10.14 192.168.100.3
Peer LDP Ident: 192.168.100.2:0; Local LDP Ident 192.168.100.1:0
TCP connection: 192.168.100.2.31760 - 192.168.100.1.646
State: Oper; Msgs sent/rcvd: 45/44; Downstream
Up time: 00:32:32
LDP discovery sources:
GigabitEthernet1/0, Src IP addr: 192.168.10.9
Addresses bound to peer LDP Ident:
192.168.10.9 192.168.100.2
core#
PE1#sh mpls ldp neighbor
Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.2:0
TCP connection: 192.168.100.1.646 - 192.168.100.2.31760
State: Oper; Msgs sent/rcvd: 43/44; Downstream
Up time: 00:31:35
LDP discovery sources:
GigabitEthernet1/0, Src IP addr: 192.168.10.10
Addresses bound to peer LDP Ident:
192.168.10.10 192.168.100.1 192.168.10.13
PE1#
PE2#show mpls ldp neighbor
Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.3:0
TCP connection: 192.168.100.1.646 - 192.168.100.3.26601
State: Oper; Msgs sent/rcvd: 37/45; Downstream
Up time: 00:25:54
LDP discovery sources:
GigabitEthernet1/0, Src IP addr: 192.168.10.13
Addresses bound to peer LDP Ident:
192.168.10.10 192.168.100.1 192.168.10.13
PE2#
Kelima: Buat Router Virtual (VRF : Virtual Routing Forwarding)
---------------PE1-----------------------
ip vrf cnc1
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface GigabitEthernet2/0
ip vrf forwarding cnc1
ip address 192.168.10.2 255.255.255.252
---------------PE2-----------------------
ip vrf cnc1
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface GigabitEthernet2/0
ip vrf forwarding cnc1
ip address 192.168.10.17 255.255.255.252
-----------------------------------------
untuk pengecekan : ketikan show ip vrf (name)
Keenam: Menambahkan Routing DiRouter Virtual
---------------PE1-----------------------
router ospf 100 vrf cnc1
log-adjacency-changes
redistribute bgp 100 subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.0.0.0 0.255.255.255 area 0
-----------------------------------------
---------------PE2-----------------------
router ospf 100 vrf cnc1
log-adjacency-changes
redistribute bgp 100 subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.0.0.0 0.255.255.255 area 0
-----------------------------------------
Ketujuh: Aktifkan MP-BGP
---------------PE1-----------------------
router bgp 100
bgp router-id 192.168.100.2
bgp log-neighbor-changes
neighbor 192.168.100.3 remote-as 100
neighbor 192.168.100.3 update-source Loopback0
!
address-family ipv4
neighbor 192.168.100.3 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.100.3 activate
neighbor 192.168.100.3 send-community both
exit-address-family
!
address-family ipv4 vrf cnc1
redistribute connected
redistribute ospf 100 vrf cnc1 match internal external 1 external 2
no synchronization
exit-address-family
!
-----------------------------------------
---------------PE2-----------------------
router bgp 100
bgp router-id 192.168.100.3
bgp log-neighbor-changes
neighbor 192.168.100.2 remote-as 100
neighbor 192.168.100.2 update-source Loopback0
!
address-family ipv4
neighbor 192.168.100.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.100.2 activate
neighbor 192.168.100.2 send-community both
exit-address-family
!
address-family ipv4 vrf cnc1
redistribute connected
redistribute ospf 100 vrf cnc1 match internal external 1 external 2
no synchronization
exit-address-family
-----------------------------------------
Untuk pengecekan : ketikan show ip vrf (name)
PE1#sh ip route vrf cnc1
Routing Table: cnc1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
C 192.168.10.0 is directly connected, GigabitEthernet2/0
B 192.168.10.16 [200/0] via 192.168.100.3, 00:21:01
10.0.0.0/32 is subnetted, 2 subnets
O 10.14.200.1 [110/2] via 192.168.10.1, 00:24:00, GigabitEthernet2/0
B 10.14.200.2 [200/2] via 192.168.100.3, 00:21:01
PE1#
PE2#sh ip route vrf cnc1
Routing Table: cnc1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/30 is subnetted, 2 subnets
B 192.168.10.0 [200/0] via 192.168.100.2, 00:16:32
C 192.168.10.16 is directly connected, GigabitEthernet2/0
10.0.0.0/32 is subnetted, 2 subnets
B 10.14.200.1 [200/2] via 192.168.100.2, 00:16:32
O 10.14.200.2 [110/2] via 192.168.10.18, 00:19:02, GigabitEthernet2/0
PE2#
Setelah selesai sesi ini, sudah bisa ping antar PE1 ke PE2, selanjutnya adalah setting CE nya agar bisa berkomunikasi dengan cabang lainya dengan virtualisasi VRF yang disetting barusan.
Berikut detail nya
---------------cnc1_a--------------------
cnc1_a#sh run
!
version 12.4
!
hostname cnc1_a
!
enable secret 5 $1$3b6r$LdDX1wajQUqjGJPOpxH0F1
!
ip cef
!
interface Loopback0
ip address 10.14.200.1 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.1 255.255.255.252
negotiation auto
!
ip forward-protocol nd
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 xxxx
login
!
end
--------------cnc1_b---------------------
cnc1_b#sh run
!
version 12.4
!
hostname cnc1_b
!
enable secret 5 $1$BNrz$gJwJXNoaDp5X0F2ViVllF/
ip cef
!
interface Loopback0
ip address 10.14.200.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.18 255.255.255.252
negotiation auto
!
ip forward-protocol nd
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password xxxx
login
!
end
Pengujian silahkan ping dari CE1 ke CE2 dan sebaliknya. Berhasil pastinya
Kalo sedikit lupa isi / penjelasan command di dalemnya bisa baca catatan berikut:
http://www.almuhibbin.com/2011/05/ringkasan-pelatian-router-telkom-2011.html
Kalo sedikit lupa isi / penjelasan command di dalemnya bisa baca catatan berikut:
http://www.almuhibbin.com/2011/05/ringkasan-pelatian-router-telkom-2011.html
Contributed Thanks to : Hafiz Maulana, Abdillah Arifin Rahman, Irfan Irawan (Sabtu, 1 Mei 2013 Tifa Building)